「Oracle エラー ORA-01805」は何を示していますか? - WKB16369
症状
- Empower クライアントにより、次記のメッセージセンターエラーが生成される:Oracle エラー ORA-01805:日付/時刻操作でエラーの可能性があります
- 取り込んだデータに、異常なまたは変な日付のタイムスタンプが見られる
環境
- Empower 3 FR2、FR3、FR4、FR5
原因
Oracle は、欠落しているか破損している、またはサーバータイムゾーンファイルと一致していない、LAC/E32(取り込みサーバー)にインストールされた Oracle タイムゾーンファイルを参照しようとしています。これは、タイムスタンプが Empower データベースサーバーではなく LAC/E32 から参照されている場合に、バッファリング中に見られます。
解決策
- 他のクライアントから、欠落しているファイルをコピーまたは追加するか、破損したファイルを置換します。
追加情報
Empower DVD からインストールすると、Empower FR2 と FR3 にはデフォルトで 14 のタイムゾーン .dat ファイルが 2 セットあります。
FR4 には、デフォルトでは 18 のタイムゾーン .dat ファイルが 2 セットあります。
FR5 には、デフォルトで 31 の timezone.dat ファイルがあります。異なる国や州によって行われたタイムゾーンの変更に対応するために、Oracle の管理者が Empower データベースサーバーに、Oracle によってリリースされたより新しいタイムゾーンファイルを追加することがあります。Empower データベースサーバーにあるすべての LAC/E32 または取り込みクライアントに同じファイルを追加する必要があります。そうしないと、バッファリングが発生したときに、異常なまたは変なタイムスタンプが表示されます。
LAC/E32 または取り込みサーバークライアントで Oracle クライアントのタイムゾーンファイルがある場所の例
C:\Empower\Oracle\Oracle11gClient_4\oracore\zoneinfo
Empower データベースサーバーで Oracle クライアントのタイムゾーンファイルがある場所の例:
H:\Empower\Oracle\Oracle18c\oracore\zoneinfo
パーソナルワークステーションで Oracle クライアントのタイムゾーンファイルがある場所の例:
C:\Empower\Oracle\Oracle11gClient_4\oracore\zoneinfo
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