RDP を使用して Citrix サーバーに接続すると、クリップボードからのコピーと貼り付けが機能しない - WKB227656
Article number: 227656To English version
症状
- ローカルでのクリップボードのコピー/貼り付けは機能する
- クリップボードからリモートでコピーできない
環境
- Empower
- Citrix サーバー
- Citrix サーバーへの RDP 接続
原因
これは Empower が引き起こした問題ではありません。CRI-3480 として提起されました(将来の CU で Citrix の修正が必要になる可能性があります)。
解決策
Citrix が公開しているメモ帳を中間ツールとして使用します。
Empower からコピーして、公開済みのメモ帳アプリに貼り付けます。
公開済みのメモ帳アプリからコピーして、ローカルマシンに貼り付けます。
追加情報
RDP は Empower でテストされていません。以下もこの問題に役立つ可能性があります。
ユーザーをリモートデスクトップのユーザーグループに追加します。
すべての Citrix サーバーおよび Citrix クライアントで、「リモートデスクトップ接続」のローカルデバイスとリソースの設定を確認します。クリップボードとドライブを有効にする必要があります。
すべての Citrix サーバーで[ローカルグループポリシーエディター]を確認します。移動先:
コンピューターの構成\管理用テンプレート\Windows コンポーネント\リモートデスクトップサービス\リモートデスクトップセッションホスト\デバイスとリソースのリダイレクト\クリップボードのリダイレクトを許可しない
[無効]に設定されていることを確認します
この問題は、多くのフォーラムで文書化されています。推奨される回避策:
- リモートコンピューターおよび Citrix クライアント(または RDP 接続を開始しているコンピューター)のタスクマネージャーを使用して、プロセス rdpclip.exe を強制終了します。
- [ファイル名を指定して実行]コマンドに移動し、アプリケーション rdpclip.exe を起動します。
id227656, EMP2LIC, EMP2OPT, EMP2SW, EMP3GC, EMP3LIC, EMP3OPT, EMP3SW, EMPGC, EMPGPC, EMPLIC, EMPOWER2, EMPOWER3, EMPSW, SUP, エンタープライズ