新しいクライアントインストールで Empower を起動すると、TNSnames.ora ファイルがクライアントにある場合でも、エラーが発生する:接続するデータベースのサービス名を入力します。
Article number: 96089To English version
症状
- 新しいクライアントで Empower を起動すると、エラーが発生する:
- 接続するデータベースのサービス名を入力します。ネームサービスを使用していない場合は、Net Configuration Assistant を使用してサービス名を定義する必要がある場合があります。
- クライアント上の TNSnames.ora ファイルが動作中のクライアントから正しいファイル場所(例:C:\Empower\Oracle\Oracle19cclient\network\admin)にコピーされている
- TNSnames.ora ファイルに正しいデータベースインフォメーションとサービス名が含まれている
- TNS ping がクライアントから正常に行われる
環境
- Empower 3
- Empower エンタープライズ
原因
クライアントのインストールが TNSnames.ora ファイルを読み取っていません。
解決策
- Empower のログイン ウィンドウにデータベース サービス名を入力します。
- ログインします。
- ユーザーがログインすると、サービス名がドロップダウンにリストされるようになりました
追加情報
このメッセージは、TNS_ADMIN 環境変数が Empower クライアントマシンで設定されており、その変数が間違ったパスを示している場合に発生することがあります。 Empower は既定ではインストール時にこの変数を使用しませんが、NuGenesis Oracle クライアントなどの他の Oracle クライアントソフトウェアのインストーラーを使用して設定できます。 Windows でこのシステム環境変数を Empower Oracle クライアントのホームパスに設定すると、Empower は tnsnames.ora を見つけることができるはずです。
id96089, EMP2LIC, EMP2OPT, EMP2SW, EMP3GC, EMP3LIC, EMP3OPT, EMP3SW, EMPGC, EMPGPC, EMPLIC, EMPOWER2, EMPOWER3, EMPSW, SUP