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Waters Japan

結果の承認後またはバックグラウンド解析で、Empower 3 から NuGenesis にレポートが印刷されない - WKB15794

Article number: 15794To English version

症状

  • Empower の結果を承認した後、NuGenesis WebVision にレポートが表示されない
  • バックグラウンド解析で UNIFY にレポートメソッドを印刷した後、NuGenesis WebVision にレポートが表示されない
  • [SDMS アーカイブプロパティ]画面で[OK]をクリックすると、Empower システム管理プログラムがクラッシュする。

環境

  • Empower 3 エンタープライズ
  • Empower 3 は、署名後に NuGenesis UNIFY にレポートを印刷するように設定されている

原因

  1. NuGenesis UNIFY プロキシープロセスが、UNIFY 印刷ジョブのオーナーと同じアカウントで実行されていません。エンタープライズバージョンの Empower では、バックグラウンド解析での印刷または承認後の印刷は WatersService によって処理されるため、印刷ジョブの所有者は OS ユーザーアカウントではなく、サービスアカウントになります。
  2. Empower でのユーザー環境設定が無効です

解決策

  1. マシンで WatersService が不要な場合は、サービスを停止してください。これにより、承認時印刷ジョブのプロセスが Empower.exe にシフトされます。Empower クライアントプロセスは通常、ユーザーのログオンセッションでユーザーのログオン ID を使用して実行されますが、WatersService はユーザーのログオンアカウントとは異なるサービスアカウント(LocalSystem、Local Service、Network Service、またはドメインの名前付きアカウント)として実行されます。
  2. 正しいユーザーアカウントで UNIFY プロキシープロセスを確認し、開始します。
    1. UNIFY のプリンターキューを開き、中止している印刷ジョブの[オーナー]列をメモします。
    2. Windows タスクマネージャーを起動し、プロキシープロセスを探します。
      • NuGenesis 9:NGprox.exe
      • NuGenesis 8:NG80prox.exe
    3. 中止しているジョブのオーナーと同じアカウントで実行されているプロキシープロセスがない場合、ジョブは完全には処理されません。
    4. コマンドラインツール「runas」を使用して、正しいアカウントで UNIFY プロキシープロセスを開始します
      • NuGenesis 9 の例:runas.exe /user:domain\serviceUser "Drive:\Program Files (x86)\Waters\NGSDMS\UV\NGprox.exe"
    5. UNIFY プリンターキューで中止しているジョブをクリアします
  3. UNIFY プロキシープロセスが正しいアカウントで実行されていても、ジョブが処理されない場合:
    1. 管理者権限で Empower にログインし、システム管理を開きます。
    2. [表示]メニュー > [環境設定をコピー]をクリックします。
    3. [ソースユーザー]を「システム」に設定します。
    4. ソースプロジェクトにプロジェクトを選択します。
    5. [ユーザーにコピー]リストで適切なユーザー名を選択します。
    6. 環境設定がすべてのプロジェクトにコピーされるように、[プロジェクト]リストの下にある[すべて選択]ボタンをクリックします。
    7. [OK]をクリックして、コピープロセスを開始します。このプロセスは、多くのプロジェクトが選択されていると完了するまでに長時間かかることがあります。

追加情報

Empower で[承認時に NuGenesis へ印刷]オプションをインストールおよび設定する方法も参照してください

この問題については欠陥報告 CRI-2175 が提出されました。

Empower ワークステーションには WatersService がないため、レポートは Empower アプリケーションによって直接印刷され、印刷ジョブの所有者は OS ログオンアカウントになります。

NuGenesis SDMS の「SDMS ログイン」コンポーネント(NuGenesis LMS ベースキット ISO ファイルで使用可能)は、システムサービスから UNIFY 印刷ジョブによって生成される問題を解決するためのものです。ただし、NuGenesis 8 Feature Release 1 以降、このコンポーネントは以前のバージョンで起こったように、ngprox プロセスを開始しません。

WatersService は、LAC/E ボックスとして機能するマシン、または装置をコントロールするマシンで実行する必要があります。この場合、最適なオプションは、RunAs.exe ツールを使用して、サービスと同じログオン ID で NGProx を起動することです。分析専用のマシンでは、WatersService をオフにすることができます。これは推奨される回避策です。

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