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NuGenesis SDMS にログインすると、「LDAP driver reports error: Connect error (-11) ... certificate verify failed」(LDAP ドライバーレポートのエラー:接続エラー (-11) ... 証明書を検証できませんでした)が表示される - WKB208063

Article number: 208063To English version

症状

  • ユーザーが NuGenesis SDMS アプリケーションにログインしようとすると、以下のエラーメッセージが表示される:
    • The following error occurred while connecting to server <servername:port>(サーバー <サーバー名:ポート> に接続するときに以下のエラーが発生しました)
    • [NG17543] LDAP driver reports error : Connect error (-11) :([NG17543] LDAP ドライバーレポートのエラー:接続エラー (-11):)
    • error:14090086:SSL(エラー:14090086:SSL)
    • routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed(ルーチン:SSL3_GET_SERVER_CERTIFICATE:証明書を検証できませんでした)
    • (certificate has expired)(証明書の有効期限が切れています)
    • Connect error(接続エラー)
    • Unable to bind to LDAP server(LDAP サーバーにバインドできません)

環境

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS

原因

  • LDAP サーバーによって送信された証明書の有効期限が切れています
    • または、LDAP サーバーのルート CA 証明書の有効期限が切れています
  • SDMS サーバーのシステムクロックが、証明書の有効範囲外の時間に変更されました。
  • LDAP サーバーの証明書が、Certificate Revocation List(証明書取り消し一覧)に追加されました。

解決策

  1. LDAP システム管理者と協力して、有効な証明書をインストールしてください。
  2. 問題が解決されない場合は、SSLTap ツールを使用して、LDAP サーバーが送信した証明書を確認します
  3. SSLTap ツールによって保存された証明書の[発行者]フィールドを確認します。Windows の[信頼されたルート証明書]ストアで、一致する証明書名を探します。このエラーは、発行者の証明書が信頼されたルートストアに存在しない、または存在しているが期限切れている場合に発生する可能性があります
  4. 信頼されたルートストアが変更された場合は、再起動するまで証明書のキャッシュされたコピーを使用するため、LDAP 接続を再試行する前に SDMS Administrator を再起動します

追加情報

 

id208063, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG