メインコンテンツへスキップ
Waters Japan

NuGenesis LMS インターフェースの[分析結果]ウィザードで、分析メソッドリストが空白である - WKB22004

Article number: 22004To English version

症状

  • SDMS または Empower から結果を受信するように NuGenesis Smart Builder フォームを設定しているとき、[分析結果ウィザード]で分析メソッドのリストが空白になる
  • [分析結果ウィザード]のテストおよび結果マッピングが保存できないか、フォームが以前に保存されている場合は、赤色のエラーアイコンで表示される

環境

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS
  • NuGenesis LMS-SDMS インターフェース
  • NuGenesis LMS-Empower インターフェース

原因

選択した分析システム(SDMS または Empower)の LMS 装置ハブにデータがありません。

解決策

  1. 分析システムから LMS 装置ハブにデータを送信します:
    1. SDMS の場合(LMS-SDMS インターフェースがインストールおよび設定されており、分析メソッドリストが空白のままであると仮定):
      1. NuGenesis サーバーで「NuGenesis SDMS Metadata Export」サービスおよび「NuGenesis LMS SDMS Interface Service」サービスを起動します。
      2. NuGenesis サーバー上の「%programdata%\Waters\SDMS Result Extractor\SDMS2ELN.ini」を編集し、「ELNConnect」行に正しい ELN サーバーのホスト名を指定します。
      3. ELNUser 行および ELNPasswd 行に有効な LMS ユーザー名およびパスワードを指定します。
      4. SDMS2ELN.ini を保存して閉じます。そのファイルが変更された場合は、「NuGenesis LMS SDMS Interface Service」を再起動します。
      5. インターフェースサービスのログファイルでエラーメッセージを探します:%programdata%\Waters\SDMS Result Extractor\Logging
      6. サービスが開始されており、エラーがログ記録されない場合は、NuGenesis WebVision の少なくとも 1 つの記録のメタデータタグを「Reprocess」(再解析)に設定します。メタデータタグは、SDMS メタデータエクスポート規則設定で、「ステータスラベル」として定義されます。
    2. Empower の場合(インターフェースがインストールおよび設定されており、リストが空白のままである場合:
      1. Empower にログインして、プロジェクトを開きます。
      2. 結果タブを選択します。
      3. いくつかの結果を選択し、[LMS]メニュー > [LMS に結果を送信]をクリックします。
      4. %ALLUSERSPROFILE%\AppData\Roaming\Waters\LMS Empower Interface\Log\ResultSender.log でエラーを探します。
  2. [分析結果ウィザード]を閉じてから再度開いて、[分析メソッド]リストを再読み込みします。

追加情報

[分析結果ウィザード]により、分析メソッドのリストが LMS データベースから取得されます。特に、elnprod.instrumenthub テーブルから。このテーブルは、LMS Smart Builder フォームおよび/または LMS サンプル管理によって解析するために、他のアプリケーションから LMS に送信されたデータを保持します。分析メソッドのリストが空白の場合、選択した分析システムに対してこのテーブルが空であることを意味します。データが装置ハブ(Empower インターフェースの)にプッシュされていないか、インターフェースが正しく設定されていない/機能していません。

id22004, ELN, EMP2LIC, EMP2OPT, EMP2SW, EMP3GC, EMP3LIC, EMP3OPT, EMP3SW, EMPGC, EMPGPC, EMPLIC, EMPOWER2, EMPOWER3, EMPSW, password, SDMS, SDMS8, SDMS8NU, SUP, SUPISDMS, SUPNG