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正しい WSMService URL を使用しているにもかかわらず、1 つまたは複数の WSM Empower エージェントが WSM ダッシュボードに表示されない - WKB246956

Article number: 246956To English version

症状

  • 1 つまたは複数の Empower ノードが WSM ダッシュボードに表示されない
  • これらのノード上の WSM エージェントサービスは、正しい WSMService URL を使用する
  • WSM エージェントのログファイルに以下のメッセージが表示される:
    • System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. ---> System.Security.Authentication.AuthenticationException: The remote certificate is invalid according to the validation procedure. (System.Net.Http.HttpRequestException:要求の送信中にエラーが発生しました。 ---> System.Net.WebException:基本接続が閉じられていました:SSL/TLS セキュリティチャンネルの信頼関係を確立できませんでした。 ---> System.Security.Authentication.AuthenticationException:検証手順に従って、リモート証明書が無効です。)

環境

  • WSM 2.x

原因

WSMService の IIS でのバインドで、期限切れの証明書または自己署名証明書が使用されています。

解決策

  1. WSM Web サーバーで[IIS マネージャー]を開きます。
  2. [Default Web Site]を開き、[バインド]をクリックします。
  3. https バインドを選択し、[編集]をクリックします。
  4. [表示]ボタンをクリックします。
  5. 証明書の[発行先]、[発行者]、および[有効期間]の情報を確認します。
    • 証明書の有効期限が切れており、認証機関によって発行された場合、サーバー用の新しい証明書を要求します。
    • 証明書の有効期限が切れており、自己署名証明書(つまり、[発行先]と[発行者]フィールドが同じ)である場合は、IIS の[自己署名入り証明書の作成]機能を使用して、新しい証明書を作成します。
    • 証明書の有効期限が切れていない場合は、発行 CA の証明書が、ログオンしたユーザーのアカウントではなく、コンピューターアカウントの[信頼されたルート証明機関]ストアに追加されていることを確認します。自己署名証明書の場合、追加する証明書は自己署名証明書自体です。
  6. WSM エージェントのサービスを再起動します。

追加情報

 

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