メインコンテンツまでスキップ
Waters Japan

NuGenesis SDMS アーカイブエージェントが起動せず、ログファイルに書き込まない - WKB251394

Article number: 251394To English version

症状

  • NuGenesis サービス設定コンソール (SCC) でアーカイブエージェントモジュールが起動しない
  • AA は通常のログファイル NGSDMSAAActivity.log を書き込まない
  • SDMS ファイルキャプチャーコンポーネントの Auto IQ ログファイルはクリーンで、エラーや警告が表示されていない

環境

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS

原因

1 つの DLL ファイル NGArchiveAgentDll.dll が登録されていません。

解決策

  1. NuGenesis RPC サービスを停止します。
  2. コマンドプロンプトを管理者権限で実行し、DLL を登録します。
    • NuGenesis 9:C:\Windows\Microsoft.Net\Framework\v4.0.30239\regasm.exe「ドライブ:\Program Files (x86)\Waters\NGSDMS\Common Files\NGArchiveAgentDLL.dll」/codebase /verbose
    • NuGenesis 8:C:\Windows\syswow64\regsvr32.exe「ドライブ:\Program Files (x86)\NuGenesis 8.0\Common Files\NGArchiveAgentDll.dll」
  3. NuGenesis RPC サービスを再起動します。
  4. SCC にログインし、AA モジュールが起動したかどうかを確認します。

追加情報

NuGenesis 9 では、DLL の NG9 バージョンが .NET アセンブリーになるように Microsoft.NET Framework を使用するために、コードが書き換えられるため、DLL を登録する別の手順が必要です。このような DLL には「DllRegisterServer」機能がなく、したがって regsvr32.exe と互換性がありません。NG8 バージョンのファイルは .NET Framework を使用しないため、regsvr32.exe で登録されます。

この問題についてはリクエスト CRI-5410 が提出されました。

id251394, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG