メインコンテンツへスキップ
Waters Japan

VISION でプロジェクトビューを読み込むと、NuGenesis 9.3 が「Cannot retrieve records」(記録を取得できません)と表示する - WKB254006

Article number: 254006To English version

症状

  • 多数の記録が含まれているプロジェクトビューを読み込むと、新しい NuGenesis 9.3 VISION アプリにエラー「Cannot recover records」(記録を取得できません)が表示される
  • 観察されたエラーメッセージ:
    • Cannot retrieve records.
    • Connection request timed out. The server could not be reached or is taking too long to respond.

環境

  • NuGenesis9.3 SDMS

原因

これは、NuGenesis 9.3 VISION アプリの既定のタイムアウト設定が 30 秒の結果です。大規模なプロジェクトを読み込む場合(例えば、以前のバージョンからの移行の後)、タイムアウトに達すると、以下のエラーが生成されます。

VISIONTIMEOUT.png

解決策

  1. ファイル「ドライブ:\Program Files (x86)\Waters\NGSDMS\Application Server\Vision\SdmsVision\assets\config\envConfig.json」を開きます。
  2. 「defaultRequestTimeout」の値を 30 からはるかに大きな値(600 など、下記に示すように)に変更します。

    {

        "hostname":  "NG93WEBSRVR",

        "projectsPort":  "54823",

        "projectServersPort":  "54824",

        "identityPort":  "54825",

        "userPreferencesPort":  "54826",

        "auditTrailPort":  "444",

        "domain":  "domain.com",

        "defaultRequestTimeout":  "600"

    }

  3. 変更を保存し、IIS および NuGenesis VISION サービスを再起動し、ブラウザーのキャッシュをクリアします(キャッシュのクリアが必要です)。

追加情報

 

id254006, SDMS, SDMS8, SDMS8NU, SUPISDMS