NuGenesis SDMS の新しい WebVision アプリで記録を電子署名することも注釈を付けることもできない - WKB284911
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症状
- WebVision で電子署名が記録されると、以下のエラーメッセージが表示される:
- 記録に署名できませんでした。リクエストの処理中にエラーが発生した。
- WebVision で記録にノートを追加すると、以下のメッセージが表示される:
- コメントを追加できませんでした。要求の処理中にエラーが発生しました。
- Web ブラウザーの Dev Tools(開発ツール)で、「esignatures」(電子署名)のリクエストが HTTP エラーコード 500 を返す
- SdmsProjects サイトのログファイルに以下のエラーメッセージが表示される:
- 文字列「DATE TIME」が有効な DateTime として認識されませんでした。
- 「DATE TIME」のプレースホルダーは、MM/DD/YYYY HH24:MI:SS 形式の日付時刻スタンプを表します。
環境
- NuGenesis 9 SDMS
原因
NuGenesis Web サーバーのサービスアカウントで、英語以外の米国の日付形式が設定されました。
解決策
- 各 NuGenesis Web サーバーで、[コントロールパネル]\の地域アプリを開きます。
- 形式を英語(米国)に設定します。
- [短い日付形式]を M/d/yyyy に設定します。
- [長い日付形式]を MMMM d, yyyy に設定します。
- [Administration](管理)タブをクリックします。
- Copy Settings(設定のコピー)ボタンをクリックします。
- チェックボックスを選択して、現在の設定を[ようこそ]画面とサービスアカウントにコピー。
- [ようこそ]画面のフォーマットとして「English (United States)」(英語(米国))が表示されます。
- 変更を有効にするために、サーバーを再起動します。
- 再起動後、必要な形式に変更できますが、形式設定をサービスアカウントにコピーしないでください。
追加情報
この問題は、WebVision が電子署名記録の現在の日付と時刻を要求するときに、Oracle データベースによって送信される日付形式が原因です。NuGenesis データベースは英語(米国)の日付形式を使用するため、日付/タイムスタンプは常に MM/DD/YYYY HH24:MI:SS の形式で返されます。IUSR サービスアカウントのコンテキストで実行される WebVision アプリは、データベースから受信した日付スタンプを解析するために、同じ日付形式を使用する必要があります。
OS の地域が[English (United States)](英語(米国))に設定されているが、長い日付および短い日付が既定以外の形式に設定されている場合、注釈のサーバーの日付/タイムスタンプの日および月の数字が置き換えられます。現在の日付が月の 13 日から月の終わりまでの場合、日付形式は YYYY-DD-MM と表示されるが、.NET によって YYYY-MM-DD として解釈されるため、操作は失敗します。現在の日付がその月の 1 日から 12 日の間の場合、操作は正常に行われますが、記録されたサーバーの日付/時刻が「YYYY-DD-MM」として表示されます。
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