NuGenesis LMS Toolbox を使用するときに、エラー「Failed to connect to Oracle database」(Oracle データベースに接続できませんでした)が表示される - WKB29852
Article number: 29852To English version
症状
- NuGenesis LMS Toolbox を使用してデータをエクスポートまたはインポートすると、以下のメッセージが表示される:
- 「Failed to connect to Oracle database」(Oracle データベースに接続できませんでした)
- Toolbox インターフェースで選択された Oracle サービスが有効であり、データベース自体が実行されている
環境
- NuGenesis 8 LMS
- NuGenesis 8 ELN
原因
- Oracle クライアント(NuGenesis に付属の Waters Oracle クライアントなど)がインストールされていますが、選択したサービス名がクライアントの tnsnames.ora にありません。
- Toolbox で指定された ELNPROD ユーザーのパスワードが正しくありません。
解決策
- Oracle クライアント設定を確認します:
- [スタート]メニューまたは[スタート]画面から Waters Net Configuration Assistant を実行します。
- Toolbox で選択された「Oracle サービス」は、クライアントの tnsnames.ora ファイルのエイリアスと一致する必要があります。
- 例:Toolbox で「SDMS8.WORLD」が選択されている場合、Configuration Assistant には、エイリアスが「SDMS8」であるエントリーが必要です
- 選択したエイリアスを持つエントリーが存在しない場合は、ファイルでエントリーを作成します
- 多くの場合、正しいデータベースホスト、サービス名、ポート番号がファイルにありますが、名前は異なっています。
- このケースでは、新しい行を作成し、正しいエイリアスを指定し、既存のエントリーからホスト名、サービス名、およびポート番号をコピーします。
- 変更された設定を保存します。
- ELNPROD に正しいパスワードを指定します。
- Toolbox の[ユーザー]リストには、データベースの Oracle アカウントのリストが表示されます。Toolbox では「ELNPROD」のみを使用する必要があります。
- パスワードボックスで、ELNPROD に正しいパスワードを指定します。
- パスワードは「elnprod」に初期設定されていますが、これは NuGenesis 8 の ELNPROD アカウントの既定のパスワードではありません。
- [次へ]ボタンをクリックして、データベースとの接続性を確認します。
- データベースへの接続が失敗するままの場合は、Toolbox のログファイルで詳細を確認します。
- 既定のログファイルの場所は %TEMP%\Toolbox.log です。
- ログファイルへのパスについて、Toolbox インストールフォルダーのファイル ELNToolbox.exe.config で確認します。
追加情報
Toolbox は、[基本設定]メニューを介して、Toolbox で設定された設定ファイルから、Oracle サービスのリストを持ち込みます。このパスは多くの場合、NuGenesis Oracle サーバーの Oracle ホームパス、または少なくとも完全な Oracle 11g クライアントホームです。Toolbox は、エクスポートまたはインポートのためにデータベースに接続しようとする場合、TNS_ADMIN システム変数を介して接続します。この変数は多くの場合、Toolbox で設定した Oracle ホームとは異なる Oracle クライアントインストール(NuGenesis 用の Waters Oracle クライアントなど)をポイントしています。すべての Oracle クライアントの tnsnames.ora ファイルおよび sqlnet.ora ファイルに、NuGenesis データベース用の同じ接続情報があることを確認します。
id29852, export, NGLMS, NGLMSLIC, NGLMSOPT, password, SUPNG