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NuGenesis RPC サービスが実行されているが、NGD ファイルが TE TEMP から移動しない - WKB66330

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症状

  • NGD ファイルは NuGenesis TE_TEMP フォルダーに存在するが、ファイルは処理されない
  • NuGenesis RPC サービスが実行されている
  • Windows タスクマネージャで、NGRPCService.exe プロセスが実行されているが、リストに NGRPCShadowServer.exe プロセスがない
  • トランスポートエンジンが起動しない

環境

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS

原因

NuGenesis RPC サービスユーザーの Temp フォルダーに空の「TETime.ini」ファイルが存在します。または、「%APPDATA%」という名前のファイルが C: ドライブに存在します。

解決策

  • 0 バイトの NGTETime.ini ファイルの場合は:
    1. NuGenesis RPC サービスアカウントの Temp フォルダーで TETime ファイルを探します。一時フォルダーは通常、Waters Tof または C:\Temp です。サービスがネームドユーザーアカウント(ローカルおよびおドメインアカウントのいずれか)で実行される場合、INI ファイルは C:\Users\username\AppData\Local\Temp にあります。
    2. TETime ファイルを削除します:
      • NuGenesis 9:NGTETime.ini
      • NuGenesis 8:NG80TETime.ini
    3. NuGenesis RPC サービスを再起動します。
    4. この問題については不具合報告 CRI-611 が提出されました。NuGenesis 9.0.2 で修正されましたが、SDMS ソフトウェアが新規にインストールされた場合のみです。9.0.2 更新プログラムには、不具合報告 CRI-611 の修正が含まれていませんでした。この修正は、9.0.2 にアップグレードされたシステムのソフトウェアパッチとして、Waters とは別の場所で入手できます。このパッチの入手については、Waters テクニカルサポートまたはフィールドサービスエンジニアにお問い合わせください。
  • C:\ ドライブ内のファイルの場合は:
    1. C:\ フォルダーで「%APPDATA%」という名前のファイルを探します。非表示のファイルおよびシステムファイルが Windows エクスプローラーに表示されていることを確認します
    2. 見つかった場合、これらのファイルを削除します

追加情報

ファイルが存在するがサイズが 0 バイトの場合、NuGenesis RPC サービスはこの状態になります。ファイルが存在しない場合、サービスは新しい TETime ファイルを構築します。この問題については欠陥報告 CRI-611 が提出されました。

場合によっては、データベースサーバーを再起動すると、この問題が解決されることもあります。

さらに観察したところ、お客様が D: ドライブで TEMP フォルダーを作成した場所では、もともと C:Temp フォルダー構造でこのファイルを見つけることができませんでしたが、さらに詳しく調べると、別のドライブで別の TEMP ファイルを見つけました。上記のディレクトリーを使用してすぐに問題が解決されない場合は、他のドライブを確認することをお勧めします。

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