アーカイブビットは、NuGenesis アーカイブエージェントによってキャプチャーされたファイルではリセットされません - WKB7620
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症状
- ファイルが NuGenesis SDMS によって適切にキャプチャーされない
- SDMS アーカイブエージェントのアクティビティログファイルに以下のメッセージが表示されます。
- ResetArchiveBit。ファイル \\servername\sharedfolder\path\filename.ext のアーカイブビットのリセットに失敗しました
- アーカイブビットをリセットできません。ユーザーの設定に従い、ロールバックを実行します。
環境
- NuGenesis 9 SDMS
- NuGenesis 8 SDMS
原因
NuGenesis RPC サービスユーザーには、ファイルの属性を変更する権限がありません。
解決策
- NuGenesis RPC サービスユーザーを識別します。
- ファイルが保存されているマシンにログインし、共有フォルダーを参照します
- 共有フォルダーの[プロパティ]ページを開き、[セキュリティ]タブをクリックします
- NuGenesis RPC サービスユーザーはこのタブにリストされており、最低でもフォルダーへの読み取りおよび書き込みのアクセス許可を持つ必要があります
- ファイルを NuGenesis データ管理によって削除する場合、削除のアクセス許可が必要です
- サービスユーザーをこのリストに追加し、読み取りおよび書き込みのアクセス許可を付与して、このアクセス許可をすべてのサブフォルダーに伝達します
- NuGenesis アーカイブエージェントによってスキャンされるすべての共有フォルダーに対して、ステップ 1 ~ 5 を繰り返します
追加情報
NuGenesis RPC サービスアカウントをVグループに追加することは推奨しません。このグループメンバーシップにより、アカウントが既定ですべてのマシンですべての共有ファイル/フォルダーを完全にコントロールできるようになり、セキュリティ上のリスクが生じます。NuGenesis によってスキャンされる共有フォルダーにおいて、サービスアカウントに必要な権限(読み取り、書き込み、およびオプションの削除)のみを付与します。
サブフォルダーも含めて、すべてのフォルダーで[読み込み専用]の属性を削除します。
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