メインコンテンツへスキップ
Waters Japan

NuGenesis LMS にログインできない。「DEPLOYMENTS IN ERROR」(展開にエラーが発生しました)が server.log ファイルに表示される - WKB78521

Article number: 78521To English version

症状

  • NuGenesis LMS にログインしようとすると、ユーザーに次のエラーメッセージが表示される。
    • There was no endpoint listening at http: //servername:8180/vp/services/LoginWsService that could accept the message(http: //サーバー名:8180/vp/services/LoginWsService でメッセージを受け取るエンドポイントがリスニングしていません)
  • エラーメッセージでは、NuGenesis LMS Server サービスは、与えられている URL のマシン名で開始されている
  • LMS サーバーのログファイルに以下のエラーメッセージが表示される。
    • 2019-10-07 22:01:57,672 ERROR [ProfileServiceBootstrap] (Thread-2) Failed to load profile:: org.jboss.deployers.client.spi.IncompleteDeploymentException: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS):

      DEPLOYMENTS IN ERROR:
        Deployment "vfs:///D:/WatersELNServer/Jboss-6.0....ecurity-mx.sar" is in error due to the following reason(s): java.lang.NullPointerException
        Deployment "vfs:///D:/WatersELNServer/Jboss-6.0....deploy/eln.ear" is in error due to the following reason(s): javassist.NotFoundException: com.creon.common.security.LoginResult

環境

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS
  • NuGenesis 8 ELN

原因

LMS サーバーで無効なセッションファイルが作成されました。この無効なセッションファイルにより、サーバーが起動できず、ポート 8180 でリッスンできません。

解決策

  1. LMS サーバーのセッションフォルダーに移動します。
    • 例:ドライブ:\WatersLMSServer\Jboss-6.0.0.Final\SessionFiles
  2. 「-sessions.store」という名前のファイルを探します。このファイルを削除するか、SessionFiles フォルダーから別の場所に移動します。
  3. LMS Server サービスを再起動します。

追加情報

ソフトウェア不具合 (D_300127_05323) は NG8 FR1 で修正されています

id78521, ELN, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG

  • この記事は役に立ちましたか?