Windows 10 バージョンで Empower 3 FR4 のインストールが失敗し、Windows の青色画面エラーが発生する - WKB112294
症状
- Empower 3 FR4 のインストール中に、Windows 10 の青色画面の「クラッシュ」が発生する
- エラー - PAGE FAULT IN NONPAGED AREA(非ページ化領域でページフォールトが発生しました)
- エラー - hardlock.sys
- コンピューターの再起動後、Empower アイコンは存在するが、Empower のインストールが完了していない(例えば、Oracle がインストールされない可能性がある)
環境
- Empower 3 FR4
- Empower 3 FR4 エンタープライズクライアント
- Windows 10 バージョン 2004、OS ビルド 19041 および 19042.685
- Windows 10 20H2
- Windows LTSB 2021 を使用する Config 17 LACE
原因
この問題は、Windows 10 バージョン 2004 および Empower 3 FR4 メディアで提供されている Smartbear TestExecute 11 のバージョンとの非互換性により発生します。
解決策
- Empower ソフトウェアを削除します。
- https://support.smartbear.com/testcomplete/docs/licensing/license-manager.html から SmartBear License Manager コンポーネントをダウンロードしてインストールします。
- Empower 3 FR4 をインストールします。
追加情報
ユーザーライセンスキーについてのプロンプトが表示されたら、SmartBear License Manager インストーラーを終了できます。この時点で、ライセンスキーが作成または更新されなくても、必要なライセンスマネージャコンポーネントはすでにインストールされています。
SmartBear License Manager のインストールがエラーで失敗した場合
「Installing license manager: Failed to execute with code 65584. The installation will rolled back」(ライセンスマネージャのインストール:コード 65584 で実行できませんでした。インストールはロールバックされます)
Windows イベントビューアーにエラーがないかを確認します。
コマンドプロンプト (cmd) を開きます
netstat -aon と入力します
ポート 1947 がリストにあるかを確認します。
ポート 1947 がリストにある場合は、最後の番号(ここでは 3376)を読み取ります
タスクマネージャに移動し、PID(例では 3376)でプロセスを強制終了します
SmartBear License Manager をインストールします
再起動後、SmartBear License Manager のインストール前にプロセスを強制終了し(この例では KService.exe)、Windows サービス[Sentinel LDK License Manager]を起動します
Empower 3 FR4 のインストール後、Windows サービス[Sentinel LDK License Manager]を無効にします。
id112294, EMP2LIC, EMP2OPT, EMP2SW, EMP3GC, EMP3LIC, EMP3OPT, EMP3SW, EMPGC, EMPGPC, EMPLIC, EMPOWER2, EMPOWER3, EMPSW, Enterprise, SUP