NuGenesis LMS-SDMS インターフェースウィザードにログインできない - WKB18325
Article number: 18325To English version
症状
- SDMS Extract Results Wizard(結果抽出ウィザード)にログインすると、以下のメッセージが表示される。
- 「Login to LMS Failed: Please check connectstring and credentials.」(LMS にログインできませんでした:接続文字列および資格情報を確認してください。)
環境
- NuGenesis 9 LMS
- NuGenesis 8 LMS
- NuGenesis 8 ELN
原因
- SDMS2ELN.ini ファイル内のログイン資格情報または接続 URL が無効です
- LMS-SDMS インターフェースのバージョンが LMS SDK のバージョンと同じではありません
解決策
- LMS SDK および LMS-SDMS インターフェースの Auto IQ プログラムを実行します。
- IQ ログファイルのマイナーバージョン番号を比較します。
- 実施例:「NuGenesis LMS SDK 9.0.2 Service Release」および「NuGenesis LMS SDMS Interface V2.0.2」
- 非実施例:「NuGenesis LMS SDK 9.0.2 Service Release」および「NuGenesis LMS SDMS Interface V2.0」
- マイナーバージョンが一致しない場合は、インストールメディアから正しいバージョンの LMS-SDMS インターフェースをインストールします。
- 設定:
- NuGenesis LMS SDMS Interface サービスを停止します。
- C:\ProgramData\Waters\Sdms Result Extractor にあるファイル SDMS2ELN.ini を編集します。
- ELNUser および ELNPasswd を有効な LMS ユーザー名およびパスワードに設定します。
- ELNConnect 文字列に LMS サーバーの正しいホスト名または完全修飾名、ポート番号 8180、および「/vp/services/」が含まれていることを確認します。
- NuGenesis 9.3 以降の場合、既定のポート番号は 8443 です
- ファイルを保存して閉じます。
- サービスを開始します
- NuGenesis LMS Server サービスが LMS サーバーで開始されていることを確認します。ユーザーが LMS にログインできることを確認します。
追加情報
LMSが LDAP 認証用に設定されている場合に、サービスが SYSTEM アカウントで設定されると、以下のメッセージが表示されます:
「DATE TIME,942 [6] ERROR Waters.ELN.ToolKit.SessionContext [(null)] - logon failed with reason 4」(日付 時間、942 [6] エラー Waters.ELN.ToolKit.SessionContext [(null)] - ログオンが理由 4 で失敗しました)
id18325, NGLMS, NGLMSLIC, NGLMSOPT, password, SUPNG