メインコンテンツへスキップ
Waters Japan

Agilent OpenLab CDS ChemStation 版から NuGenesis UNIFY に印刷できない - WKB29322

Article number: 29322To English version

症状

  • OpenLab CDS ChemStation 版から UNIFY に印刷すると、印刷ジョブが完了しない
  • UNIFY プリンターのキューで、印刷ジョブのステータスが「スプール中」であり、Windows にログインしたユーザーアカウントとは異なるユーザーアカウントが所有する
  • 手動モード印刷で、UNIFY タグのダイアログボックスが表示されない

環境

  • NuGenesis 8 SDMS
  • Agilent OpenLab CDS ChemStation 版、バージョン C.01.0x

原因

OpenLab ソフトウェアは、ユーザー自身のセッションとは別に、リモートデスクトップセッションでデータ分析プログラムを実行します。設計により、この別のセッションは、ユーザー自身のログオン ID とは異なるユーザー ID を使用します。結果として、印刷ジョブのオーナーはユーザーの ID ではありません。別のセッションで実行されている NG80prox.exe プロセスが印刷ジョブを取得し、印刷プロセス中に([ロットモード]印刷であっても)ダイアログボックスが表示されると、印刷ジョブが停止します。ダイアログボックスはリモートデスクトップセッションに表示され、ユーザーには見えません。

解決策

  1. データ分析アプリケーションのリモートデスクトップセッションが作成されるときに、ChemStation アプリケーションによって使用されたものと同じアカウントで、Windows にログインします。これにより、NG80prox.exe プロセスは印刷ジョブを取得し、ユーザーのセッションに必要なダイアログボックスをディスプレーします。
  2. 上記の回避策ができない場合、NuGenesis UNIFYプリンターを使用して OpenLab CDS ChemStation からレポートをキャプチャーできません。
  3. ChemStation からのレポートを PDF ファイルとしてディスクに保存し、NuGenesis ファイルキャプチャーエージェントと抽出テンプレートを使用して PDF ファイルをアーカイブします。

追加情報

 

id29322, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG, アジレント