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Waters Japan

NuGenesis LMS での Java ヒープスペースチューニング - WKB3269

Article number: 3269To English version

症状

  • NuGenesis LMS クライアントを介してドキュメントを開くときに、エラーメッセージを受け取ることがあります。
  • LMS クライアントのログファイルに記録されるエラーメッセージ(一部)は「Caused by: java.lang.OutOfMemoryError: Java heap space」です。
  • このエラーは、より大きいドキュメント(大きな高解像度のイメージが多数あるドキュメント、または多数のドキュメントセクションがあるドキュメント)で、発生する可能性がより高いです。

環境

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS
  • NuGenesis 8 ELN

原因

Java Runtime Environment は、サーバーがユーザーのリクエスト(ドキュメントを開くなど)に対応するための十分なメモリーを、LMS サーバーに割り当てることができません。

解決策

  1. メモ帳でファイル Drive:\WatersLMSServer\javaServiceWrapper\conf\wrapper-jboss.conf を開きます。
  2. 以下の行を探します。
    • # Maximum Java Heap Size (in MB).
    • wrapper.java.maxmemory=
  3. Wrapper.java.maxmemory のデフォルト値は 1024 です。その数値を GB 単位の数値に等価な別の数値(たとえば、4 GB の場合は 4096)に変更します。
  4. ファイルを保存して閉じます。
  5. NuGenesis LMS Server サービスを再起動します。

追加情報

NuGenesis LMS Server は、Java ランタイム環境で動作する 64 ビットアプリケーションです。JRE は、初期化パラメーターによってシステムからメモリーを割り当てます。このパラメーターは、その環境内で実行される Java アプリケーション(LMS サーバーの場合は、Java アプリケーションは LMS Server サービスの 1 つがあるだけ)で使用可能になります。すべてのインストールで JRE のヒープ割り当ての上限を 4 GB に引き上げ、サーバー負荷にとって 4 GB では十分でないことが判明した場合は、さらに引き上げることをお勧めします。LMS でのすべてのユーザー操作は、メモリーの使用を招きます。メモリーは必要がなくなると解放されますが、一部の操作ではより大きなメモリー割り当てが必要な場合があります。

LMS クライアントのログファイルは、ユーザープロファイルフォルダー内の AppData フォルダーに保存されます。 LMS クライアントがユーザーの PC でローカルに実行される場合、AppData フォルダー(および LMS ログファイル)は PC にローカルに保存されます。LMS が Citrix クライアントを介して実行される場合、ログファイルは Citrix サーバー上のユーザーのプロファイルフォルダーにあります。ファーム内に多数の Citrix サーバーがあるか(ユーザーがファーム内の様々なサーバーにリダイレクトされる場合)、または Citrix プロファイル管理が使用されている場合に、ログファイルを見つけることがさらに複雑になることがあります。プロファイル管理には多くの形態がありますが、最も一般的には、ユーザープロファイルは中央サーバー(個々の Citrix サーバーではなく)に保管されます。LMS がローカル PC で実行される場合は、PC に特定のユーザーとしてログインしているときに、PC の[スタート] > [実行]プロンプトで以下のパスを指定することで、ログファイルを見つけられます。

  • NuGenesis 8 LMS:%AppData%\Waters\NuGenesis LMS\version\Product.log
  • NuGenesis 8 ELN:%AppData%\Waters\NuGenesis ELN\version\Product.log

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