NuGenesis Unify にログインしようとすると、エラー「[NG14647] Failed to connect to the server」([NG14647] サーバーに接続できませんでした)が表示される - WKB68020
Article number: 68020To English version
症状
- NuGenesis RPC サーバーの場所を選択すると、Unify ログインダイアログボックスの近くに以下のエラーメッセージが表示される
- 「[NG14647] Failed to connect to the server.」([NG14647] サーバーに接続できませんでした。)
環境
- NuGenesis 8 SDMS
- NuGenesis 9 SDMS
原因
ユーザーのマシンが NuGenesis SDMS Web アプリケーションサーバー上の NuGenesis RPC サービスに接続できません。
解決策
- NuGenesis RPC サービスが Web アプリケーションサーバー上で開始されていることを確認します。
- TCP ポート 2500-2504 でのトラフィックが NuGenesis Web アプリケーションサーバー上のファイアウォールを通過するのをオフにするか、または許可します。
- Unify アプリは、ローカル PC 上の NGLocalProjectList.xml ファイルにある設定を使用して、Web サーバーの NuGenesis RPC サービス用のホストおよびポート番号に接続します。
- NGLocalProjectList.xml ファイルは次の場所にあります:ドライブ:\Program Files (x86)\NuGenesis 8.0\database
- NuGenesis Web アプリケーションサーバーのホスト名は、<InetAddress> パラメーターの後に続きます
- 例:<InetAddress>NG8WEBSRV</InetAddress><Port>2500</Port>
- クライアントマシンが Web アプリケーションサーバーのホスト名を解決できることを確認します。
- Web アプリケーションサーバー名をサーバーの IP アドレスにマッピングするエントリーを、クライアントマシン上の hosts ファイルに追加します。
- または、NGLocalProjectList.xml のエントリーを変更して、完全修飾ドメイン名を使用します。
- または、ご当地の IT 専門家と協力して、ホスト名に関して権限のある DNS サーバーの A レコードに、NuGenesis サーバーの正しい IP アドレスがあることを確認します。
- クライアントマシンで、Ping および NSLookup ツールを使用して NuGenesis サーバーへの接続をテストします。
追加情報
id68020, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG