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Waters Japan

エラー:NuGenesis Restore または Preview でのメッセージ「Failed to extract file(s) to folder...」(ファイルをフォルダーに抽出できませんでした...) - WKB7353

Article number: 7353To English version

症状

  • NuGenesis からファイルデータを復元するときや、印刷データを開くときに、次記のエラーメッセージが表示される:

「Failed to extract file(s) to folder<temp path>. Please ensure that there is sufficient disk space for file. If there is sufficient disk space please try again as the network\DB connection may have been lost.」 (フォルダー <一時パス> にファイルを抽出できませんでした。ファイル用に十分な空きディスク容量があることを確認してください。十分な空きディスク容量がある場合は、ネットワーク\DB 接続が失われている可能性があるため、再試行してください。)

環境

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS

原因

このメッセージは通常、ストレージ容量の不足を示しません。このエラーメッセージの最も一般的な原因は、(1) 1 つまたは複数のファイルがオフラインストレージに移動され、そのオフラインストレージデバイスがオフラインであるか、(2) ファイルが管理されたストレージプロジェクトにあり、プロジェクトの FTP ストレージの場所が使用できない。この記事では、要求されたファイル(Oracle データベース、管理されたストレージ、またはオフラインデバイスにある)の格納場所を調べるステップが、説明されています。

解決策

  1. ユーザーに NuGenesis インストールフォルダーおよびすべてのサブフォルダーへの読み取り/書き込み権限があるかを確認します。
    • NuGenesis 9 の場合:ドライブ:\Program Files (x86)\Waters\NGSDMS
    • NuGenesis 8 の場合:ドライブ:\Program Files (x86)\NuGenesis 8.0
  2. 記録がオフラインストレージおよび/または管理されたストレージプロジェクトにあるかを確認します。
    1. NuGenesis WebVision で、ファイル記録を選択し、[ファイル]メニュー > [詳細を表示] > [ファイルプロパティー]をクリックします
    2. [外への移動ステータス]列に「外へ移動済み」または「アップロード済み」と表示されている場合、そのファイルはオフラインストレージデバイスにあります。外への移動量名、外への移動デバイス名、外への移動ファイル名をメモして、記事エラー:オフラインファイル用の NuGenesis Restore でのメッセージ「Failed to extract file(s) to folder...」(ファイルをフォルダーに抽出できませんでした...)の指示に従って、さらにトラブルシューティングします
    3. 列に「Not moved out」(外に移動していない)と表示されている場合、そのファイルはオフラインストレージデバイスにありません。このファイルは、管理されたストレージサイトまたは Oracle データベースにあります。
      1. SDMS Administrator にログインします
      2. SDMS プロジェクトのプロパティページを開きます。プロジェクトのプロパティページで[管理されたストレージの場所]タブを選択します
      3. プロジェクトの管理されたストレージの場所がリストされている場合、ファイルは管理されたストレージのサイトにあります。記事エラー:管理されたストレージプロジェクトの NuGenesis Restore でのメッセージ「Failed to extract file(s) to folder...」(ファイルをフォルダーに抽出できませんでした...)の指示に従って、さらにトラブルシューティングします。
  3. ファイルがオフラインストレージデバイスに保存されておらず、プロジェクトで管理されたストレージサイトが使用されない場合、そのファイルは Oracle データベースにある必要があります
  4. NuGenesis サーバーでの Windows ファイアウォールが NuGenesis RPC サービスの既定のポートでのトラフィックを許可するかを、決定します
  5. NuGensis トランスファーアプリによって使用される一時フォルダーの場所が、クライアント/Citrix マシンで以下のレジストリーキーに設定されているのと同じであることを確認します:
    • HKLM\SOFTWARE\WOW6432Node\NuGenesis Technologies Corp.\NuGenesis\Preview\TempFolder
    • トランスファーアプリがログインユーザーの一時フォルダーを使用するように、このキーを %TEMP% に設定する必要があります
  6. ファイルが Oracle データベースにあり、NuGenesis サーバーのファイアウォールが NuGenesis RPC サービスポートのトラフィックをブロックしていないのに、問題が解決しない場合は、Waters テクニカルサポートにお問い合わせください。

追加情報

データを復元しようとするユーザーに、復元先への権限があることを確認します。

システムのセットアップ後に LDAP に変更を加えた場合は、NuGenesis RPC サービスを再起動します

id7353, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG