メインコンテンツへスキップ
Waters Japan

NuGenesis WebVision クライアントをロードすると、2 分遅れて HTTP 502.3「Bad Gateway」(ゲートウェイ不良)エラーメッセージが表示される - WKB31372

Article number: 31372To English version

症状

  • NuGenesis WebVision サイトでの読み込みが非常に遅い
  • プロジェクトビューを開くと、ブラウザーによってエラーメッセージ HTTP 502.3 「Bad Gateway」が表示される
  • Microsoft IIS ログファイルでは、WebVision サイトのログに、少なくとも 1 つのクライアント要求に対してエラーコード 502.3 および 12002 が含まれ、その要求に約 120000(120 秒)が費やされる
  • Apache Tomcat ログファイルにエラーメッセージが記録されず、Apache Tomcat 6 サービスが実行されている

環境

  • NuGenesis 9 SDMS
    • Windows Server 2016/2019 での Microsoft IIS
    • Apache Tomcat v9.x
  • NuGenesis 8 SDMS
    • Windows Server 2012 での Microsoft IIS
    • Tomcat 6.0.29

原因

コード 502.3 と 12002 は、プロキシサーバー (Apache Tomcat) からの応答を待つ間に IIS がタイムアウトすることを意味します。タイムアウトはデフォルトでは 120 秒です。タイムアウトは、Apache Tomcat サービスのフェイル、NuGenesis SDMS でのデバッグログによって発生したサーバーのパフォーマンスの遅れ、または NuGenesis 用 Oracle データベースのパフォーマンスの遅れ/応答なしのことがあります。

解決策

  1. NuGenesis SDMS Web サーバーでの Apache Tomcat 6 サービスのステータスを確認します。[Started](開始済み)または[Running](実行中)である必要があります。  Tomcat サービスを再起動します
  2. 次記の Tomcat ログファイルで最新のエラーメッセージを探します:ドライブ:\Program Files (x86)\apache-tomcat-6.0.29\logs
  3. デバッグログを無効にして、サービスを再起動します:
    1. regedit を開き、SDMS デバッグ用のレジストリーキーを探します:
      • NuGenesis 8:HKLM\Software\Wow6432Node\NuGenesis Technologies Corp.\NuGenesis\8.0\Debug
      • NuGenesis 9:HKLM\Software\Wow6432Node\NuGenesis Technologies Corp.\NuGenesis\Debug
    2. 「デバッグ」キーが存在する場合は、これを削除します
    3. regedit を閉じます
    4. 次記のサービスコントロールパネルを開きます:[スタート] > [ファイル名を指定して実行] > services.msc
    5. Apache Tomcat サービスおよび World Wide Web Publishing サービスを停止します
    6. サービス「NuGenesis VISION Server」を再起動します
    7. Apache Tomcat サービスおよび World Wide Web Publishing サービスを起動します
    8. NuGenesis RPC サービスを再起動します
    9. デバッグログを削除して、サーバーのディスクのスペースを解放します:
    10. Apache Tomcat ログファイルを削除します:
      • ドライブ:\Program Files (x86)\Waters\apache-tomcat-x.y.z\logs
  4. Internet Explorer を再起動し、Web Vision にログインして戻ります
  5. SDMS Administrator にログインし、マスターリストとローカルリストのすべてのデータベースがオンラインでアクセス可能であることを確認します。1 つ以上のデータベースにアクセスできない場合、つまり、データベースにログインするときに SDMS Admin が応答しなくなる場合は、DB がダウンしている可能性があり、再起動する必要があります
    • この問題が数人のユーザーにだけ発生する場合は、記事 wkb233236 を参照してください
  6. NuGenesis の Oracle データベースがオンライン/アクセス可能であるにもかかわらず、実行が遅い場合(多くの場合、これは SGA のサイズが不十分であるか、インデックスが不十分な結果)、タイムアウトおよび HTTP 502 エラーが発生します。データベースのパフォーマンスをトラブルシューティングするためのツールおよびサポートについては、Waters テクニカルサポートにお問い合わせください

追加情報

HTTP 502.3 エラーは、NuGenesis 8 Web サーバー上の Java ランタイム環境が Java 1.7 Update 2 以降に更新した場合も、発生します。新しい JRE は Apache Tomcat と互換性がなく、IIS に応答できないため、IIS はブラウザーに 502.3 エラーコードを表示します。NuGenesis 9 SDMS Web サーバーの Java アップグレードは、リンクされた記事の手順に従ってサポートされています。

id31372, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG, インポート