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NuGenesis LMS クライアントで LDAP 接続テストが不合格 - WKB23103

Article number: 23103To English version

症状

  • NuGenesis LMS で LDAP サーバー設定をテストすると、「User or password is incorrect!」(ユーザーまたはパスワードが間違っています!)というエラーメッセージが表示される
  • Windows、NuGenesis SDMS、または Empower にログインする場合は、同じ LDAP ユーザー名とパスワードでログインできる

環境

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS
  • NuGenesis 8 ELN

原因

  • 無効な LDAP 設定により、LMS サーバーが LDAP サーバーに接続できなくなっています。
  • LDAP サーバーはオフラインです。または
  • [テスト接続]ダイアログボックスに入力されたユーザー名が、LDAP サーバー内のエントリーのいずれとも一致しないか、複数のエントリーと一致しています

解決策

  1. LMS で LDAP 構成の各部分を確認します。
    • URL フィールドで、プロトコルの種類およびサーバー名を確認します。
      • NuGenesis 8 ~ 9.2:プロトコルは、保護されていない LDAP を使用する場合は「ldap://」、安全な LDAP を使用する場合は「ldaps://」にする必要があります
      • NuGenesis 9.3 以降:認証の種類は「LDAP SSL」または「LDAP TLS」である必要があります
      • URL のサーバー名は、有効な LDAP サーバーの名前または完全修飾名である必要があります。
    • ポートが正しいことを確認します
      • NuGenesis 8 ~ 9.2:既定のポートは、保護されていない LDAP の場合は 389であり、安全な LDAP の場合は 636 です
      • NuGenesis 9.3 以降:お客様の IT チームによって指定されない限り、「LDAP」および「LDAP TLS」の認証の種類ではポート 389 を使用するか、「LDAP SSL」には 636 を使用します
    • バインドユーザーとパスワードが正しいことを確認します
    • Base DN が正しいことを確認します
    • LDAP フィルターをクリアします
    • ユーザー ID に正しい LDAP 属性を使用します。Active Directory サーバーの場合は sAMAccountName、非 Active Directory サーバーの場合は UID です
  2. LDAP フィルターがある場合は、LDAP クエリ構文を使う必要があります。例:(objectClass=user)
    • ほとんどの場合、LDAPフィルターは必要ありません
    • 必要な場合は、フィルターの周りにかっこ()を使用します。LMS サーバーは、デフォルトのフィルターにフィルターを追加します。例:(&(uid=username)(objectClass=user))
  3. 安全な LDAP を使用している場合は、リンクされている記事の手順に従って、証明書を LMS サーバーに追加します
  4. LDAP に関連するエラーメッセージの LMS サーバーログファイルを確認します
  5. Softerra LDAP ブラウザーツールで LDAP サーバーに接続して、同じクエリを実行します
  6. LDAP サーバーが検索結果に対して複数の一致を返した場合は、LMS は、エラーメッセージを表示します

追加情報

server.log のエラーメッセージの一例は、LDAP サーバーによって提供された証明書に問題があることを示します。

  • LDAP サーバーへのアクセスの問題。例えば、ユーザーが LDAP で使用できません:javax.naming.CommunicationException: simple bind failed: ldapserver:636 [Root exception is javax.net.ssl.SSLHandshakeException: KeyUsage does not allow digital signatures](javax.naming.CommunicationException:シンプルバインドが失敗しました:ldapserver:636 [ルート例外が javax.net.ssl.SSLHandshakeException:KeyUsage がデジタル署名を許可しません])

このメッセージは、LDAP サーバー自体の証明書の KeyUsage パラメーターで「digitalSignatures」が指定されていない NuGenesis 9.3 以降のサーバーで見られます。

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